lunes, 29 de enero de 2018

ABOUT THIS BUGS XSS - CSRF - SSRF






The different Modes of Introduction provide information about how and when this weakness may be introduced. The Phase identifies a point in the software life cycle at which introduction may occur, while the Note provides a typical scenario related to introduction during the given phase.

IN OTHERS WORDS

Server Side Request Forgery (SSRF) refers to an attack where in an attacker is able to send a crafted request from a vulnerable web application. SSRF is usually used to target internal systems behind firewalls that are normally inaccessible to an attacker from the external network. Additionally, it’s also possible for an attacker to leverage SSRF to access services from the same server that is listening on the loopback interface (127.0.0.1).

Typically Server Side Request Forgery (SSRF) occurs when a web application is making a request, where an attacker has full or partial control of the request that is being sent. A common example is when an attacker can control all or part of the URL to which the web application makes a request to some third-party service.

Detecting Server Side Request Forgery (SSRF)

In order to detect Server Side Request Forgery (SSRF) automatically, we’ll need to rely on an intermediary service since the detection of such a vulnerability requires an out-of-band and time-delay vector. Acunetix solves this by making use of AcuMonitor as its intermediary service during an automated scan.

During a scan, Acunetix will make requests containing a unique AcuMonitor URL. If AcuMonitor receives a request on one of these unique URLs, it will send a notification back to Acunetix indicating it should raise an alert for Server Side Request Forgery (SSRF).

The following is the result of an Acunetix scan with AcuMonitor to detect Server Side Request Forgery (SSRF). The alert contains information about the HTTP request that was performed including the IP address of the server that made this request and the User-agent string used in the request, if any. This information can help the developers identify the source of the problem and fix it.

Mitigating Server Side Request Forgery (SSRF)

Whitelists and DNS resolution

Implementing simple blacklists or regular expressions directly on the user’s input to filter out which IP addresses or domains can make requests is a bad approach to take when mitigating an SSRF.

In general, blacklists are a poor security control because there will always be bypasses not envisaged by a developer. In this case, bypass by an attacker are as easy as using an HTTP redirect, a wildcard DNS service such as xip.io or even alternate IP encoding.

Instead, the most robust way of dealing with Server Side Request Forgery (SSRF) is to whitelist the DNS name or IP address which your application needs access to. If a whitelist approach does not suit your use case, and you must rely on a blacklist, it’s important to validate user input properly. An example of this is to not allow requests to private (“non-routable”) IP addresses (detailed in RFC 1918), however, in the case of a blacklist, the correct mitigation to adopt will vary from application to application. In other words, there is no universal “fix” to SSRF since it highly depends on the application’s functionality and business requirements.

 

Response handling

Ensuring that the response received by the remote server is indeed what the server is expecting is important to prevent any unforeseen response data leaking to the attacker. Above all else, under no circumstances should the raw response body from the request sent by the server be delivered to the client.

 

Disable unused URL schemas

If your application only makes use of HTTP or HTTPS to make requests, only allow those URL schemas. Disabling unused URL schemas will prevent a web application from making requests using potentially dangerous URL schemas such as file:///, dict://, ftp:// and gopher://.

 

Authentication on internal services

Services such as Memcached, Redis, Elasticsearch and MongoDB do not require authentication by default. Server Side Request Forgery vulnerabilities could provide an attacker with the opportunity to access some of these services without any authentication standing in the way. Therefore, it’s best to enable authentication wherever possible as another defense mechanism.

OBTAINED FROM DIFFERENT SOURCES
Acunetix: www.acunetix.com/blog/articles/server-side-request-forgery-vulnerability/
& others great authors


+ Applicable Platforms
 
The listings below show possible areas for which the given weakness could appear. These may be for specific named Languages, Operating Systems, Architectures, Paradigms, Technologies, or a class of such platforms. The platform is listed along with how frequently the given weakness appears for that instance.
Languages

Class: Language-Independent (Undetermined Prevalence)

Paradigms

Web Based (Undetermined Prevalence)

Technologies

Web Server (Undetermined Prevalence)

+ Common Consequences

The table below specifies different individual consequences associated with the weakness. The Scope identifies the application security area that is violated, while the Impact describes the negative technical impact that arises if an adversary succeeds in exploiting this weakness. The Likelihood provides information about how likely the specific consequence is expected to be seen relative to the other consequences in the list. For example, there may be high likelihood that a weakness will be exploited to achieve a certain impact, but a low likelihood that it will be exploited to achieve a different impact.



Technical Impact: Execute Unauthorized Code or Commands
   
+ Notes

Relationship
 
CWE-918 (SSRF) and CWE-611 (XXE) are closely related, because they both involve web-related technologies and can launch outbound requests to unexpected destinations. However, XXE can be performed client-side, or in other contexts in which the software is not acting directly as a server, so the "Server" portion of the SSRF acronym does not necessarily apply.

lunes, 8 de enero de 2018

WPHARDENING - Chequeo de seguridad de WORDPRESS




Antes de comenzar con este artículo amigos cabe señalar que esta herramienta lanza nuevas versiones regularmente. Asegúrense de actualizar sus dependencias con frecuencia para obtener la última versión consultando el registro de cambios o CHANGELOG.md para conocer las nuevas funciones.

WPHardening es una herramienta para automatizar y realizar diversos chequeos de seguridad para que nuestra web este configurada de forma segura y como podemos ver esta hecha en python y la mas nueva versión es la v 1.6 basados en la revisión del changelog que esta en el siguiente link:

https://github.com/elcodigok/wphardening/releases

Entre las opciones de seguridad que tiene esta gran utilería podemos describir las siguientes:

  • Modificar los permisos de los archivos a 755 en el directorio y 644 en archivos.
  • Eliminar archivos y directorios.
  • Creación de los famosos y bien ponderados ROBOTS.TXT.
  • Eliminar huellas de IDENTIFICACIÓN DE WORDPRESS.
  • Cambio de propietario de archivos y directorios. 
  • Descargar complementos de seguridad. 
  • Utilizar un proxy HTTP para conectarse a la URL de destino.
  • Negar  la visualización de contenidos de los directorios. 
  • Comprimir archivos estáticos .css y .js. 
  • Escanear en busca de Malware en el proyecto de WordPress.
  • La posibilidad de usar FIREWALL 6G.
  • Desactivación de las API´s REST.

Como pueden ver amigos esta utilería es de gran ayuda  para la configuración y hardening de nuestro WORDPRESS, pero cabe señalar que si bajas un plugin con vulnerabilidades esto no lo podrá parar. ok.


INSTALACIÓN

Los creadores de esta utilería no la pusieron muy fácil la instalación ya que con el siguiente comando lo podremos instalar en LINUX.

$ pip install -r requirements.txt
 
 
  y además podremos bajar varios plugins con los acules podremos interactuar para mejorar mas la seguridad en WORDPRESS.

  • AntiVirus
  • Bad Behavior
  • Block Bad Queries
  • Exploit Scanner
  • Latch
  • NinjaFirewall
  • Simple History
  • Stream
  • WP Security Scan
  • WP-DBManager
  • WPS Hide Login 
 Que ya en breve explicaremos uno a uno en coordinación y apoyo a la página:


 
 





Saludos y nos vemos en la próxima edición.

LI. Rodolfo h. Baz

viernes, 15 de diciembre de 2017

NEUTRALIDAD DE INTERNET - R.I.P. ++





 La muerte del internet neutral, trae consigo una terrible posibilidad de que las empresas, decidan limitarnos el acceso a internet como ellas decidan y a cobrarnos como les plazca, si quieres ver una pelicula !paga!. si quieres bajar exploits !NO por que no esta permitido!, si quieres navegar por una enciclopedia !NO, por que te haces mas inteligente!, si quieres bajar software !NO lo tienes permitido!, si quieres ver porno !paga! mmmm....

LINK DE ARTICULO COMPLETO

martes, 21 de noviembre de 2017

INTEL SEcurity BUGs News 21-11--2017

HACKED   INTEL AGAIN

Los siguientes productos Intel: 

-- Management Engine
-- Server Platform Services 
-- Trusted Execution Engine. 

Son vulnerables a  un ataque donde podría aprovechar algunas de estas vulnerabilidades para tomar el control de un sistema afectado.



Intel ha identificado varias vulnerabilidades de seguridad que podrían poner en riesgo las plataformas impactadas. 

Los sistemas que utilizan ME Firmware versiones 11.0 / 11.5 / 11.6 / 11.7 / 11.10 / 11.20, SPS Firmware versión 4.0 y TXE versión 3.0 se ven afectados. 

PRODUCTOS AFECTADOS


  • 6th, 7th & 8th Generation Intel® Core™ Processor Family
  • Intel® Xeon® Processor E3-1200 v5 & v6 Product Family
  • Intel® Xeon® Processor Scalable Family
  • Intel® Xeon® Processor W Family
  • Intel® Atom® C3000 Processor Family
  • Apollo Lake Intel® Atom Processor E3900 series
  • Apollo Lake Intel® Pentium™
  • Celeron™ N and J series Processors

En función de los elementos identificados a través de la revisión de seguridad integral, un atacante podría obtener acceso no autorizado a la plataforma, la función Intel® ME y secretos de terceros protegidos por Intel® Management Engine (ME), Intel® Server Platform Service (SPS) o Intel® Trusted Execution Engine (TXE). 

INTEL ha sacado una utilería para detectar estos problemas en los sistemas afectados y la pueden bajar de aquí:




esperemos QUE LES AYUDE ESTA INFORMACIÓN AMIGOS   (Y)

PARA MAYOR SOPORTE Y EXPLICACIÓN DE ESTE BUG PUEDEN CONSULTAR EL SIGUIENTE LINK:

Management Engine Critical Firmware Update (Intel SA-00086)


Li. Rodolfo H. Baz
www.rodolfohbaz.net





miércoles, 1 de noviembre de 2017

Profesor x -All activation Windows (7-8-10) v17.0 2017.iso


Despues de un rato de andar verificando los activadores de WINDOWS ALL VERSIONS y demas activadores que existen.

aqui les dejo los que a mi me han funcionado y que sirven, se los dejo en una  iso 

por favor si la descargan dejen seeds para que todos puedan descagarla facilmente.

lunes, 30 de octubre de 2017

Deactive Windows 10 Defender & Notice Patch v 1.0


Buen día amigos

Hace ya unos días acabo de instalar windows 10 en una laptop que tengo y me di cuenta que tiene muchísimas aplicaciones que no son necesarias y que solo causan espacio y lentitud en el sistema operativo en cuestión, tales como:

-- El centro de actividades
-- Windows Defender

que son para mi los mas importantes y que causan mucha molestia al usar windows y ni tarde ni presuroso me puse a crear un parche que resolviera esa situación y que desactivara o eliminara estas dos aplicaciones molestas y aquí les dejo la tool.

Las instrucciones de uso vienen en la tool, dejándoles esta imágenes donde se muestra el parche y lógicamente su Checksum de validez.


 DESCARGAR...

Le dejo aquí la imagen donde se hace una revisión de esta tool con kaspersky para corroborar que no es un virus ok.

Una vez aplicado el parche, deberán de reiniciar su sistema.



Cualquier duda, me pueden contactar y recuerden en breve sacaremos la v 2.0 de este parche de actualización. 

pd: recuerden ejecutarlo como administrador.

Saludos 

Li. Rodolfo H. Baz
www.rodolfohbaz.net

lunes, 16 de octubre de 2017

Video demostración - Nuevo ataque wireless -WPA2 KRACK





bUEN DÍA AMIGOS les dejo aquí el video de demostración de este nuevo ataque. donde al verlo me surgieron varias preguntas y que trataré de contestar.


  1. En que consiste el ataque en detalle?
Este ataque va dirigido al haandshake que sta estructurado de 4 formas en el protocolo WPA2. el HAndshake se ejecuta cuando un cliente desea unirse a una red Wi-Fi protegida, y se utiliza para confirmar que tanto el cliente como el punto de acceso poseen las credenciales correctas (por ejemplo, la contraseña precompartida de la red). 
Al mismo tiempo, el handshake también negocia una nueva clave de cifrado que se utilizará para cifrar todo el tráfico subsiguiente. Actualmente, todas las redes Wi-Fi protegidas modernas utilizan el protocolo de enlace de 4 vías. Esto implica que todas estas redes se ven afectadas por (alguna variante de) de este ataque. 
Por ejemplo, el ataque funciona contra redes Wi-Fi personales y empresariales, contra el WPA anterior y el último estándar WPA2, e incluso contra redes que solo usan AES. Todos nuestros ataques contra WPA2 usan una técnica novedosa llamada ataque de reinstalación clave (KRACK).}

 2.- Este ataque en que sistemas es mas peligroso?
 
Bueno amigo basados en la descripción e investigación de este,  es especialmente catastrófico contra la versión 2.4 y superior de wpa_supplicant, un cliente Wi-Fi comúnmente usado en Linux. Aquí, el cliente instalará una clave de cifrado totalmente cero en lugar de volver a instalar la clave real. Esta vulnerabilidad parece ser causada por una observación en el estándar Wi-Fi que sugiere borrar la clave de cifrado de la memoria una vez que se instaló por primera vez. Cuando el cliente recibe ahora un mensaje retransmitido 3 del enlace de 4 vías, volverá a instalar la clave de cifrado ahora borrada, instalando de manera efectiva una clave de cero. Como Android usa wpa_supplicant, Android 6.0 y superior también contiene esta vulnerabilidad. Esto hace que sea trivial interceptar y manipular el tráfico enviado por estos dispositivos Linux y Android. 

Tenga en cuenta que actualmente el 41% de los dispositivos Android son vulnerables a esta variante excepcionalmente devastadora.

 2.- Cambiar la contraseña de tu wifi ayudará a protegerse?

LAMENTABLEMENTE NO, PERO ESnÍ mantengan actualizados sus sistemas con los parches que ya ha sacado OPENBSD y WINDOWS 10.

 3.- Se pueden snifear datos una vez hecho el ataque?

SI.  up´s   amigos...

 4.- Que diferencia tiene este ataque wpa a los otros existentes?

Este es el primer ataque contra el protocolo WPA2 que no se basa en adivinar la contraseña. De hecho, otros ataques contra la red habilitada para WPA2 están en contra de las tecnologías circundantes, como Wi-Fi Protected Setup (WPS), o son ataques contra estándares más antiguos como WPA-TKIP. Dicho de otra manera, ninguno de los ataques existentes estaba en contra del apretón de manos de 4 vías o en contra de los paquetes de cifrado definidos en el protocolo WPA2. En contraste, nuestro ataque de reinstalación clave contra el apretón de manos de 4 vías (y contra otros apretones de manos) resalta las vulnerabilidades en el protocolo WPA2 en sí mismo.



 5.- Sabian ustedes que OpenBSD?

YA habia sacado en silencio un parche de actualización...


se ve intersante hay que probarlo, en unos días daremos un jemplo en vivo (Y) saludos


jueves, 12 de octubre de 2017

lockpicking 2 = Mama.. Mamaa..... quiero ser cerrajero



lockpicking 2 = Mama.. Mamaa..... quiero ser cerrajero....Todas las técnicas mostradas son para conocer que tan fácil nos pueden robar y entender que lo que tu creías seguro... adivina.... NO LO ES.......(y)





lunes, 9 de octubre de 2017

Códigos de respuesta devueltos por el protocolo FTP





Después de unos cuantas semanas de no escribir nada, hoy pondré información que es indispensable a la hora de usar el Puerto 21, Servicio FTP y lógicamente un servidor FTp y que son los:
Códigos de respuesta de FTP

Como sabemos en los protocolos de comunicación existen códigos de respuesta que se maneja entre CLIENTE-SERVIDOR  SERVIDOR-CLIENTE  y que sirven para saber acerca de la conexión que se lleva a cabo en estos servicios ý además es bueno mencionar que también  estos códigos están estandarizados y destinados
a dar una descripción intuitiva de lo que sucede en la conexión y especificados por el RFC 2616 (actualmente obsoleto), y algunos fragmentos en los estándares RFC 2518 (también obsoleto), RFC 2817, RFC 2295 (experimental), RFC 2774 (también experimental) y RFC 4918; otros no están estandarizados, pero son comúnmente utilizados.
Los mas comunes y que vemos mas son los del protocolo HTTP  y que por poner un ejemplo se dividen en:

  • RESPUESTAS INFORMATIVAS 

  • PETICIONES COMUNES

  • REDIRECCIONES

  • ERRORES DEL CLIENTE
  •  
  • ERRORES DEL SERVIDOR
Pero realmente como decía lineas arriba son las mas conocidas, aquí hablaremos de estos mismos códigos pero del servicio FTP.
A continuación se muestra un resumen de la respuesta de los códigos FTP que puede ser devuelto por un servidor FTP y Estos códigos se han estandarizado en RFC 959 por IETF con lo cual el código de respuesta es un valor de tres dígitos donde el primer dígito se utiliza para indicar uno de tres posibles resultados 
El éxito - El fracaso - El error - La respuesta incompleta: 

  • 2yz - respuesta Éxito
  • 4yz o 5yz - No hay respuesta
  • 1yz o 3yz - Un error o una respuesta incompleta.

 

El segundo dígito define la clase de error:
  • x0z - Sintaxis. Estas respuestas se refieren a errores de sintaxis.
  • x1z - Información. Las respuestas a las solicitudes de información.
  • x2z - Conexiones. Respuestas en referencia al control y las conexiones de datos.
  • x3z - Autenticación y contabilidad. Respuestas para el proceso de inicio de sesión y los procedimientos contables.
  • x4z - No definido.
  • x5z - Sistema de archivos. Estas respuestas transmiten códigos de estado del sistema de archivos del servidor.
 Y para finalizar el tercer dígito del código de respuesta se utiliza para proporcionar detalles adicionales para cada una de las categorías definidas por el segundo dígito.

Como pueden ver amigos estos son algunos de los códigos de respuesta y además nos da a entender lo que realmente pasa ahí dentro de ese protocolo y su forma de funcionar.


Espero les guste.

Li Rodolfo H. Baz
www.ccat.edu.mx

viernes, 15 de septiembre de 2017

NO ES LO MISMO LLEGAR EN CHANCLAS QUE PRESENTABLE


TOTALMENTE CIERTA ESTA PREMISA¿

-------------- Porque lo digo? bueno les contaré la historia -----------
Hace 15 días que nació mi hijo y lógicamente estábamos pensando mi esposa y yo  a que pediatra llevarlo para su primera revisión de salud y ver todo eso de las vacunas y llevar su control de bebe con pediatra, entonces recordé que había llevado ya hace más de 17 años a mi primer hijo con una doctora en Coatepec, Ver. llamada:

---SOLER CHAVEZ MA ESTHER Pediatra----
 
Entonces ni tarde ni presuroso hice la cita para llevarlo a su consulta y para no hacérselas cansada llegó el día de la consulta, me levante, tenía mucha flojera y me puse el pantalón de mezclilla más viejo que tenía y mis tenis viejitos Nike, pero ya medio gastadones por comodidad y recuerdo que hasta le pregunté a mi esposa " Corazón será que me vaya así vestido o me arreglo?"  a lo que ella me contesta, sí solo vamos a una consulta con la Dra. así vete no creo que sea problema. 




Ok! me subí con mi esposa y el bebe a mi camioneta NISSAN KICKS 2017 ya que la que tenia una Renault STEPWAY me la robaron si amigos me la robaron y ya algún día de estos contaré la historia jejejejejeje y pues ni modo a comprar otra.


Nos fuimos al Dr., me presente con mi esposa al consultorio a las 11.20 y la cita era a las 12:00 ok llegue con buen tiempo y a esperar, dieron las 12 y la dra. no llegaba las 12.30 y por fin llegó.

Entramos a consulta........ y una vez en consulta la dra. nos dijo pónganlo en la mesa de exploración y así lo hicimos, lo revisó y dijo que todo estaba perfectamente bien y eso me alegro muchísimo y continuo la dra. hablado sobre diferentes cosas y cuestiones que le preguntábamos sobre el bebe, y en ese momento le pregunté:

Dra. Que vacunas se le tiene que poner a mi Hijo para que quede protegido y así llevar su control de todas ellas? ---------------

y ella me contesto:

Bueno se le tiene que poner 5 vacunas, pero esas yo no las regalo, a mí me cuestan y yo no las regalo, en Salubridad si las regalan. 🤔     

Y que volteo a ver a mi esposa y con la mirada le dije queee le pasa a la dra. si no le voy a pedir regalado.......

A lo cual le conteste:    Haber dra. soy el papa de IVAN H.S que usted le llevó el control por más de 5 años cuando fue BB que no recuerda quién soy? 😎

Y en ese momento expresa: 

Ahh! si se me hacía conocido sr. Rodolfo Hernández Baz 

Inmediatamente cambio su tono de platica y la forma de ofrecer sus servicios.

Claro sr. Rodolfo al finalizar la consulta pase con mi secretaria y le dirá los costos de las vacunas................. up´s 🤑🤑🤑🤑🤑🤑

Sin más que comentar con esto amigos doy como cierta la premisa de la imagen:

NO ES LO MISMO LLEGAR EN CHANCLAS QUE PRESENTABLE

y dejamos la moraleja: Como te ven, te tratan, y como te ves, ¡te pagan!



Ojala la Dra. pudiera ver quien soy yo y no se base en lo que ve, ademas sea lo que sea si se pide una consulta todo el dinero vale sea quien sea. www.rodolfohbaz.net 


A eso como le podríamos llamar amigos??

Ya en breve pondré en este blog otros datos de discriminación en otros lugares que eh visto como en el HOspital CIvil de Coatepec y deveras ahí si que están muchísimo peor..... hasta se sorprenderán...

esperenlos

CONVERTOR X V 1.0 y los principales desafíos o problemas que surgen al convertir entre estos formatos:

    CONVERTOR X V 1.0   U na utilería diseña y creada para dar facilidad de convertir entre formatos de imagenes descargarla de aquí:  https...